]> www.average.org Git - loctrkd.git/blobdiff - debian/changelog
Update changelog for 0.99 release
[loctrkd.git] / debian / changelog
index cca13dd4d4487a2265d4494697222a976520d264..baa604703e578d7884fc17e9061d437eadfe6ca4 100644 (file)
@@ -1,3 +1,69 @@
+gps303 (0.99) experimental; urgency=medium
+
+  * Revive mkgpx example script
+  * Drop data if we are receiving junk
+  * test: fuzzing collector
+  * test: complete fuzzer unittest
+  * collector: fix problems found by fuzzer test
+  * test: make unittests individually runnable
+  * collector: enable SO_KEEPALIVE on accepted conn.
+  * test: message fuzzer and fix found problems
+  * test: move `send_and_drain` to common module
+  * test: skeleton for an end-to-end unittest
+  * test: adjust sleeps and drains when daemons run
+  * test: minimally functional test_storage
+  * do not try to use zlib's _Decompress
+  * test: use IPv4 because github actions
+  * Add sample opencellid csv for tests
+  * test: better aquisition of free ports
+  * test: opencellid downloader
+
+ -- Eugene Crosser <crosser@average.org>  Wed, 22 Jun 2022 18:04:10 +0200
+
+gps303 (0.98) experimental; urgency=medium
+
+  * include runtime deps as build-time for typecheck
+  * fix l3str/l3int breakage provoked by typeckeck
+  * make termconfig use unit specific config section
+  * expand README: lookaside and termconfig sections.
+  * wsgateway: reclassify http write hack as permanent
+  * Update README with configuring the terminal
+  * Implement remaining "Out" commands
+  * do not run black older than 21.1
+
+ -- Eugene Crosser <crosser@average.org>  Tue, 07 Jun 2022 00:17:55 +0200
+
+gps303 (0.97) experimental; urgency=medium
+
+  * adjust tests
+  * typecheck: skip test if mypy verison < 0.942
+
+ -- Eugene Crosser <crosser@average.org>  Tue, 31 May 2022 01:05:39 +0200
+
+gps303 (0.96) experimental; urgency=medium
+
+  * Do not write startup message for command-line cmds
+  * Add a (short) man page
+  * typing: make zmsg.py typecheck
+  * typing: annotate gps303proto.py (mostly)
+  * typechecking: less hacky deal with dynamic attrs
+  * typing: annotate opencellid.py
+  * typchecking: annotate googlemaps.py
+  * typechecking: annotate evstore.py
+  * typechecking: annotate common.py
+  * typeckecing: annotate ocid_dload.py
+  * typeckecing: annotate watch.py
+  * typechecking: annotate termconfig.py
+  * typeckecking: annotate storage.py
+  * typing: annotate lookaside.py
+  * typechecking: annotate collector.py
+  * typeckeck: annotate __main__ and fix gps303proto
+  * typeckecking: annotate wsgateway.py
+  * formatting: revive black formatting
+  * unittest: type checking and formatting
+
+ -- Eugene Crosser <crosser@average.org>  Tue, 31 May 2022 00:36:33 +0200
+
 gps303 (0.95) experimental; urgency=medium
 
   * Quick fix for a missing variable